Archives par mot-clé : vip

Retour d’expérience sur les adresses ip virtuelles RDS et XenApp 6.0

Bonjour,

Voici donc comme promis le retour d’expérience sur la mise en place des virtual IP avec XenApp 6.0…

Certaines applications nécessitent une IP unique par instance. Dans un environnement XenApp, c’est donc l’IP du serveur qui est retournée lors d’un appel aux APIs Winsock : problématique avec ce genre d’applications!
Les IP virtuelles ont été introduites dans CPS4.0 et Microsoft l’a implémenté dans Windows 2008 R2. Donc, depuis XenApp 6.0, il faut au minimum configurer les IP virtuelles via RDS (GPO etc) et activer les stratégies XenApp idoines si l’on souhaite davantage de fonctionnalités (VIP en loopback etc). Continuer la lecture de Retour d’expérience sur les adresses ip virtuelles RDS et XenApp 6.0

XenApp 6.x : adresses ip virtuelles

Bonjour,

Certaines applications nécessitent une IP unique par instance. Dans un environnement XenApp, c’est donc l’IP du serveur qui est retournée lors d’un appel aux APIs Winsock : problématique avec ce genre d’applications!

Les IP virtuelles ont été introduites dans CPS4.0 et Microsoft l’a implémenté dans Windows 2008 R2. Donc, depuis XenApp 6.0, il faut au minimum configurer les IP virtuelles via RDS (GPO etc) et activer les stratégies XenApp idoines si l’on souhaite davantage de fonctionnalités (VIP en loopback etc).

Jusque là tout va bien. Des essais sur mon environnement de test m’ont montré que cela fonctionne sans accro (attention, dans la GPO RDS il faut bien indiquer le sous-réseau de la NIC qui reçoit les VIP sous la forme 172.16.250.32/24 ou 172.16.250.0/24).

Mais lorsque l’on utilise VMWare vSphere 4, impossible d’avoir des IP virtuelles assignées à la session. La solution semble être la suivante (je n’ai pas encore pu tester, je modifierai ce post une fois le workaround validé).
http://communities.vmware.com/thread/255821?start=15&tstart=0

soluce:
1. add VMXNET3 adapter and remove E1000
2. uninstalling the VMCI driver by modifying the VMware Tools installation
3. disabling IPv6 by unchecking the box in the Local Area Connection properties
4. setting the DisabledComponents DWORD value to 0xFFFFFFFF under HKLMCurrentControlSetservicesTCPIP6Parameters in the registry

j’ai un souci avec cette soluce… c’est le point 3. désactiver IP v6 n’est pas recommandé par Microsoft! voir http://blogs.technet.com/b/netro/archive/2010/11/24/arguments-against-disabling-ipv6.aspx

edit (21/11/11): a priori, seule l’étape 2 est vraiment nécessaire… l’utilisation de la VMXNet3 et la désactivation de l’IPv6 n’ont rien changé..
edit2 (02/12/11): merci Nicolas D. et Nicolas H. pour les efforts ce soir! grâce à toi, Nicolas D. ça va enfin marcher… je mettrai un nouvel article avec la vrai soluce.

ThinIsFat