Archives de catégorie : alerts

Sécurité : vulnérabilité dans CPS

Bonjour,

Pour rappel, car le bulletin a déjà plus d’un mois..

Tous les détails, avec les liens vers les hotfix : http://support.citrix.com/article/CTX116941

Vulnerability in Citrix Presentation Server could allow authenticated users to gain unauthorized access to a desktop session

Severity: Medium

Description of Problem

Citrix Presentation Server provides access control to both published applications and published desktops. Under specific circumstances, an authenticated user may be able to access a desktop session despite being unauthorized to access a published desktop.

This vulnerability affects the following products:

• Citrix Presentation Server versions up to and including 4.5

• Citrix Access Essentials versions up to and including 2.0

• Citrix Desktop Server version 1.0

Mitigating Factors

The user must authenticate to Citrix Presentation Server for this vulnerability to apply.

This vulnerability can be used by an authenticated user to gain access to a desktop running in the context of their own account. It does not allow a user to gain any additional Windows privileges, access rights or capabilities.

thinisfat

 

Client ICA et Vista

Hello ! Qui utilise Vista ? pas grand monde encore… Cependant, voici quelques réponses sur le support de Vista par le client ICA :

La v.9 fonctionne-t-elle avec Vista ?

  • Oui, avec quelques limitations.

La v.10 (livré avec CPS4.5) est elle totalement compatible Vista ?

  • Non pas encore… la version officielle supportant Vista sera dispo mi 2007 plus d’infos ici

ThinIsFat.

Effet Black Hole : un serveur fait planter toute une ferme

Ce phénomène est connu depuis longtemps et Brian Madden a publié un article à ce sujet en Octobre 2004 ( http://www.brianmadden.com/content/content.asp?ID=254 ) avec une méthode pour contourner le problème.

 


Citrix a ensuite publié des hotfix pour un peu contourner ce problème via une clef de registre (SocketTimeout). Cela est inclus dans le R01 pour MPS3.0 et le SP4 pour MetaFrame XP et c’est de base dans 4.0 Citrix a tout récemment (le 16/01) publié un hotfix pour CPS 4.0 qui contourne le problème de blackhole.

Les détails sont assez techniques mais très clair et je recommande fortement d’installer ce correctif sur toute ferme CPS4 (PSE400R01W2K3010 ou PSE400R01W2K010): http://support.citrix.com/article/CTX108549 pour tous les détails et le download Si j’ai des infos concernant la disponibilité de ce correctif sur d’autres versions je ferai un edit de ce message sur le http://forum-citrix.com/index.php/topic,210.0.html ThinIsFat.